FC2ブログ

ビオラ

2010/05/20
s-2010_04_29 155054  42 R0011277
camera: GXR
lens: A12 50mm F2.5 MACRO
1/440s F2.8 ISO200
2010.04.29


鉢植えのビオラは元気です。

日本語でプログラミングできる言語「なでしこ」を使い写真整理プログラムを考えてみた。
元のファイル名にEXIFタグ取得を所得して年、月、日、時間を付け加え年、月のフォルダへ移動するものです。
10行プログラムを目標してみましたが13行かかってしまいました。
ファイルのリネームなのでカメラ付属ソフトの「Irodio Photo & Video Studio」でもフリーソフトでも、できるんですけどね


フォルダ選択して、対象フォルダに代入。
「{対象フォルダ}*.jpg;*.jpeg」の全ファイル列挙。
それを反復
 母艦のタイトルは対象。
 対象のEXIFタグ取得。
  それを反復
   対象が「DateTimeOriginal=(*):(*):(*):(*):(*)」でワイルドカード一致。
   もしそれが1ならば
    年=抽出文字列[0]。月=抽出文字列[1]。日時=抽出文字列[2]。分=抽出文字列[3]。秒=抽出文字列[4]。
 移動フォルダは「{対象フォルダ}{年}_{月}\」
 対象からファイル名抽出して元名前に代入。
 対象から「{移動フォルダ}{年}_{月}_{日時}{分}{秒} {回数} {元名前}」にファイル移動。
「終わりました」と言う。終わり。

comment (0) @ 未分類
三日月と火星 | 紅いカエデ

comment

コメントを送る。

URL:
Comment:
Pass:
Secret: 管理者にだけ表示を許可する
 
プロフィール
【送料無料】リコーGXR MOUNT A12 WORLD

リコーGXR MOUNT A12 WORLD
価格:1,995円(税込、送料無料)